Connection refused! Is selenium server started?

When you update your Google Chrome version and suddenly when you start running automation you hit the above mentioned error.

Solution

  • Get the latest chromedriver (https://sites.google.com/a/chromium.org/chromedriver/)

  • Make sure your automation framework uses the latest chromedriver


For projects using node.js, nightwatch.js, running on Mac OS use the following steps

  • Update the package.json
  • npm update

Replace

/<PWD>/node_modules/chromedriver/bin/chromedriver 

With

/<PWD>/node_modules/chromedriver/lib/chromedriver/chromedriver

You may also like...