Category: Command Line Tools

0

xcode-select: error: tool ‘xcodebuild’ requires Xcode, but active developer directory ‘/Library/Developer/CommandLineTools’ is a command line tools instance

Solution: Type below command in your terminal sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer References: https://stackoverflow.com/questions/17980759/xcode-select-active-developer-directory-error https://github.com/nodejs/node-gyp/issues/569

0

Autocomplete cli from history

Use the following steps to do the reverse search in your bash history. $ Ctrl + R $(reverse-i-search)`’: [start typing command…] [Tab/Enter] – Tab will complete the command and brings back the CLI. -...

0

$? variable in linux

$? Status of the previous process / command which ran on the shell $ pwd $ echo $? // returns 0 which means the previous command ran sucessfully $ blahCommand $echo $? // returns...

0

[Resolved] unsupported major.minor version 52.0

This is a generic issue. I solved it using the following steps. Uninstall Java completely sudo rm -fr /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin sudo rm -fr /Library/PreferencePanes/JavaControlPanel.prefPane sudo rm -fr ~/Library/Application\ Support/Java # Remove Java runtime from...