The engine yarn is incompatible with this module [Resolved]

I recently got the following error when trying to run yarn on my local mac.

The engine "yarn" is incompatible with this module.

Turns out, I had to upgrade yarn. And since I had installed it via homebrew, the following command did the job.

brew upgrade yarn
yarn # This is an alias for `yarn install`

Reference

  • https://github.com/rails/webpacker/issues/752

Ryan Sukale

Ryan is just a regular guy next door trying to manage his life and finances.

You may also like...