MSBUILD : error MSB4132: The tools version “2.0” is unrecognized. Available tools versions are “4.0”.


If you get the above error, while installing dependencies for your project you should try the following steps to resolve it.

Solution 1:

Reinstall node-gyp and then install dependencies again

npm install -g node-gyp
npm install

Solution 2:

Install relevant version of windows-build-tools

npm install -g windows-build-tools@1.3.2
npm config set msvs_version 2015

You may also like...